EC-CUBE 2.4系→2.11系へ【はじめに…】

EC-CUBEの2.11系の正式板がリリースされて早くも半年が経ちました。
移行を簡単にするモジュールが提供されており、移行は比較的簡単かと思いきや色々できないという情報を見ます。

そんな情報を横目に、どうしようかなと思っていたらバージョンアップの依頼が…

ということで業務の合間を見て情報収集からしてみました。

■ 移行モジュールについて
http://www.ec-cube.net/press/detail.php?press_id=114

移行モジュールを使用するにはEC-CUBEオーナーズストアへユーザー登録をする必要がある。また移行モジュール設置にも2つの方法があるようです。

・EC-CUBEオーナーズストア経由でダウンロード・インストールする方法
 http://store.ec-cube.net/user_data/manual.pdf

・オーナーズストアからダウンロード、直接サイトへアップロードする方法
 http://store.ec-cube.net/img/setup.pdf

なるほど…

■ 移行できるバージョンについて
対象は2.4系となっているが、フォーラムを見る限りは、先ずは2.4.2までは対応できるように進める予定とのこと。
http://xoops.ec-cube.net/modules/newbb/viewtopic.php?topic_id=7885&forum=15&viewmode=flat&order=ASC&start=0

現在はどこまで対応しているのか分かりませんでした。
また対応バージョンでもエラーが出てできないなど多くの情報があり、実際にやってみないと何とも言えないようです。

ということで実際の作業は次回にまた投稿します!!

関連記事

  1. 進化するHTML5 IMGタグ

  2. EC-CUBE3系 on Plesk! Plesk搭載サーバーでEC-…

  3. BaserCMSをテスト中!

  4. MODxでつくる!最強のCMSサイト

  5. スタバのソイラテを飲みながら、SOYCMSをやってみる

  6. WordPressもゆるキャラ